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 The synchronous generator (SG) plays a crucial role in power systems by 

serving as a stable and reliable source of electrical energy. The performance 

of an SG hinges on its standard parameters, which can be derived through 

dynamic tests. This study introduces a method for determining the standard 

parameters of an SG from dynamic tests conducted via power system 

simulation for engineering (PSS/E). The proposed method entails conducting 

several key tests on the generator, including a direct-load rejection test, 

excitation removal test, quadrature-axis load rejection test, arbitrary axis 

load rejection test, and open-circuit saturation test. The results obtained from 

these tests are then utilized to calculate the standard parameters of the SG 

accurately. To validate the effectiveness of the method, simulation data from 

the SG, as well as the designed initial data, are utilized. Statistical analysis 

reveals that the maximum relative error is equal to or less than 2.7% of the 

design values for all standard parameters, emphasizing the robustness and 

accuracy of the proposed method. The methodology presented in this study 

can complement field or site measurements, as it enables the verification of 

system parameters through dynamic simulations. 
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1. INTRODUCTION 

Electric power generation involves using various types of electric generators, each with unique 

characteristics and applications [1]. These include linear generators, which are often used in niche 

applications; induction generators, typically used in wind energy systems; and permanent magnet generators, 

valued for their high efficiency in renewable energy systems [2]. Among these, the synchronous generator 

(SG) is significant, as it efficiently converts mechanical energy into electrical energy and ensures grid 

stability. SGs are commonly employed in large-scale power plants, such as hydroelectric, thermal, and 

nuclear facilities, where they play a critical role in generating and supplying electricity to the grid. 

To determine the fundamental parameters of an SG, such as field winding characteristics, leakage 

reactions, and magnetizing and damping winding properties, it is necessary to calculate the standard parameters 

first. These standard parameters include direct-axis and quadrature-axis synchronous/reactance/transient/sub-

transient reactances, rotor time constants, inertia constant, and saturation factors at different flux levels. 

https://creativecommons.org/licenses/by-sa/4.0/
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Dynamic tests offer a means to determine these standard parameters accurately. Once obtained, mathematical 

relationships can be utilized to derive the fundamental parameters [3]. 

The proposed methods for deriving SG parameters can be categorized into two main types: standstill 

methods [4] and online procedures [5]. Standstill methods or offline procedures are mandatory tests 

conducted during generator start-up, maintenance, and service operations. These tests, such as load rejection 

and sudden short-circuit tests, are classified into time domain and frequency domain methods [6]. On the 

other hand, online procedures involve testing methods performed in real-time while the generator is in 

operation [7], [8]. 

Various methods have been proposed for modeling and parameter identification of SG, including an 

Unscented Kalman filter (UKF) [9], a Constrained Iterated Unscented Kalman Filter. (CIUKF) [10], [11], 

optimization algorithms [12], [13], maximum-likelihood estimation [14], nonlinear techniques [15], [16], 

neural networks [17], [18], trajectory sensitivities [19], [20], adaptive model [7], [21], frequency  

response [22], and load rejection dynamic tests [23], [24]. Dynamic mathematical models of SG serve as 

essential tools for understanding their behavior and predicting performance in different operating  

conditions [23]. These models play a critical role in designing, analyzing, and controlling SGs in modern 

power systems engineering [24], [25]. Dynamic tests are conducted on operating SG to determine standard 

parameters such as synchronous reactance, transient reactance, and sub-transient reactance [26]. However, 

there are concerns about the difficulty and practicality of extracting the necessary parameters from these 

tests, especially in situations where precise results are needed quickly (such as during maintenance 

shutdowns), using readily available tools [27], [28]. 

This research paper investigates the determination of SG standard parameters or system 

identification through dynamic simulation conducted using the industrial-grade power system simulation 

(PSS/E) software. The PSS/E used in this project for system identification has provided a more accurate 

representation of the system's behavior due to the practicality of the mathematical model. The proposed 

methodology in this study can complement the field or site measurement as it enables the verification of the 

system parameters through dynamic simulations. This study aims to prove the use of dynamic tests for 

accurately deriving the standard parameters of SG via system identification. It provides an overview of 

various dynamic tests that can be employed. It presents a case study demonstrating the utilization of dynamic 

tests to derive the standard parameters of an SG. 

The remaining sections of this article are structured as follows: Section 2 details the methodological 

approach employed for modeling and validating the determination of SG standard parameters. Section 3 

overviews the combined cycle power plant (CCPP), encompassing generator characteristics, selected 

dynamic models, and network topology. Section 4 presents the results obtained from the simulation 

conducted in PSS/E. In Section 5, the results obtained are thoroughly discussed and compared with results 

from other proposed methods. Finally, Section 6 presents the conclusions derived from this study. 

 

 

2. METHOD  

This section describes the methodology used to conduct the direct-load rejection test, excitation 

removal test, quadrature-axis load rejection test, arbitrary-axis load rejection test, and open-circuit saturation 

test in PSS/E. 

 

2.1.  Direct axis-load rejection test  

To determine the d-axis parameters, the generator must be connected to the grid, supplying  

the minimum possible active power, ideally at zero, and the maximum possible reactive power. The field  

test results indicate that the minimum active power is 5.8 MW with a reactive power of -16.5 MVAR  

for the steam turbine generator (STG3) and 2.3 MW with a reactive power of -16.1 MVAR for the gas 

turbine generator (GTG1 & GTG2). The d-axis parameters can be determined according to Figure 1 and  

the (1)-(3) [29]. The following steps outline how to perform the D-axis load rejection test in PSS/E:  

i) Step 1: Load the .sav case file and .sld file. 

ii) Step 2: Reduce the generator load to the minimum value determined from the field test. 

iii) Step 3: Solve the system to check for convergence. 

iv) Step 4: Prepare the converted case: 

a) Convert generators and loads: Go to Power flow > Convert Loads and Generators. 

b) Order the network for matrix operations: Go to Power flow > Solution > Order Network for Matrix 

Operations. 

c) Factorize the admittance matrix: Go to Power flow > Solution > Factorize Admittance Matrix. 

d) Set up the solution for switching studies: Go to Power flow > Solution > Solution for Switching 

Studies. 

v) Step 5: Load the dynamic file (.dyr): Go to File > Open. 
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vi) Step 6: Define channels for the output: Go to Dynamics > Channel Setup Wizard > ETRM. 

vii) Step 7: Perform the dynamic simulation: 

(a) Define the output file and initialize the simulation: Go to Dynamics > Simulation > Perform 

Simulation. 

(b) Simulate pre-fault conditioning: Go to Dynamics > Simulation > Perform Simulation > 20s. 

(c) Apply the fault by opening the generator circuit breaker. 

(d) Simulate the fault duration: Go to Dynamics > Simulation > Perform Simulation > 60s. 

viii) Step 8: Plot the output file to analyze the results: Go to File > Open. 
 

𝑋𝑑 =
𝐶

𝐼°
 (1) 

 

𝑋𝑑
′ =

𝐵

𝐼°
 (2) 

 

𝑋𝑑
′′ =

𝐴

𝐼°
 (3) 

 
 

 
 

Figure 1. Typical transient response of generator terminal voltage in direct-axis test 
 
 

2.2.  Quadrature-axis load rejection test 

To conduct the q-axis load rejection test, follow the same procedures outlined in the d-axis load 

rejection test, with one key modification in Step 2. Instead of adjusting the generator load to the minimum 

value, the load must be adjusted until the rotor angle is 90 degrees away from the reference point obtained 

during the direct-axis test. This ensures proper alignment for the q-axis analysis. The determination of the d-

axis parameters can then be performed based on Figure 1 and (4)-(6) [29]. 
 

𝑋𝑞 =
√𝐴2−𝐶2

𝐼°
 (4) 

 

𝑋𝑞
′′ =

√𝐴2−𝐶2−√𝐴2−𝐵2

𝐼°
 (5) 

 

𝑋𝑑
′′ =

𝐴

𝐼°
 (6) 

 

Where: 𝐼° is the interrupted current 

 

2.3.  Arbitrary axis load rejection test 

The arbitrary axis load rejection test follows the same procedures as described in the d-axis load 

rejection test, with two modifications. In Step 2, instead of adjusting the generator load to the minimum value, 
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it must be reduced to 18 MW. In step 6, the output for channel setup should be the speed (SPD) rather than the 

terminal voltage (ETRM). The inertia time constant (H) can be determined based on Figure 2 and (7). 
 

𝐻 =
𝑃°×𝐹°

2×
𝑑𝑓

𝑑𝑡
×𝑀𝑉𝐴𝑏𝑎𝑠𝑒

 (7) 

 

Where: 
𝑑𝑓

𝑑𝑡
 : Initial slope, 𝐹°: Base frequency, 𝑃°: load rejection 

 

2.4.  Open circuit saturation test  

To perform the open-circuit saturation test, it follows the same procedures outlined in the d-axis 

load rejection test, with two modifications. In Step 2, the generator circuit breaker should be set to open 

instead of adjusting the generator load. In Step 7(c), instead of applying a fault, it should be set to increase 

the exciter current in steps of 0.1 per unit (pu) until the maximum allowable terminal voltage is reached. The 

d-axis parameters can be determined based on Figure 3 and (8) and (9). 

 

𝑆1.0 =
𝐵−𝐶

𝐴−𝐵
 (8) 

 

𝑆1.2 =
𝐸−𝐹

𝐷−𝐸
 (9) 

 

 

 
 

Figure 2. Derivation of the inertia time constant 
 
 

  
 

Figure 3. Typical open-circuit saturation curve 
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2.5.  Excitation removal test  

The excitation removal test follows the same procedures as the d-axis load rejection test, with two 

essential modifications. In Step 2, the generator circuit breaker is set to open instead of adjusting the generator 

load. In Step 7(c), the exciter field circuit breaker is opened rather than applying a fault or manipulating exciter 

currents. These adjustments allow for the proper execution of the excitation removal test. 
 

 

3. CASE STUDY  

The simulation results presented in this study are based on a modified CCPP in Malaysia as a 

representative case study. The plant configuration includes two gas turbine units (GTG1 and GTG2) and one 

steam turbine unit (STG3), as depicted in Figure 4. These components are interconnected to form a single 

power generation block within the plant. The SG generator ratings for each unit are as follows: i) The steam 

turbine unit (STG3) is rated at 146.25 MVA, operates at 13.8 kV, and has a power factor of 0.8. It is driven 

by a steam turbine with a nameplate rating of 117 MW. ii) The gas turbine units (GTG1 and GTG2) are both 

rated at 134.625 MVA, operate at 15 kV, and have a power factor of 0.8. They are driven by either natural 

gas or distillate oil-fired turbines. 

The electromagnetic model of the round rotor generator (GENROU) was employed to accurately 

represent the gas and steam unit generators, as recommended by [30]. GENROU is a well-established 

mathematical model specifically designed to simulate the performance of round rotor generators, which are 

SGs featuring a circular rotor. By leveraging the principles of electromagnetism, this model enables the 

prediction of the generator's behavior across varying operating conditions, including different load and 

excitation levels [31]. The utilization of the GENROU model has become prevalent in the design and 

analysis of round rotor generators, providing valuable insights into their performance characteristics under 

diverse operating conditions. For a comprehensive understanding of the GENROU model, including 

saturation effects, the block diagram representation can be referred to in [32]. 
 

 

 
 

Figure 4. CCPP single-line diagram 
 

 

4. RESULTS AND DISCUSSIONS  

4.1.  RESULT 

The results of GTG1 and GTG2 are presented as one group because they share the same system 

design. However, the STG3 is presented separately due to its distinct design and operational conditions, 

which differ from those of GTG1 and GTG2. This separation allows for a comprehensive analysis of the 

performance and characteristics of each turbine type, considering their specific attributes and requirements. 

The amplification of plots is employed in the PSS/E environment to enhance the accuracy of readings and 

observations. By amplifying the plots, finer details and subtle variations in the data can be magnified and 

analyzed with greater precision. 
 

4.1.1.  Excitation removal test  

The excitation removal test is conducted to validate the generator's direct-axis transient open-circuit 

time constant (𝑇𝑑𝑜
′ ) used in the simulation. In this test, the generator operates at full speed with no load, and 

 

 

Bus 2: 11 kV 

Bus 1: 275 kV 

Bus 3: 132 kV Bus 8: 11 kV 

20 MW 

Bus 5: 33 kV Bus 4: 132 kV 

Bus 6: 132 kV 

Bus 7: 11 kV 
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the unit circuit breaker is open. The exciter field circuit breaker is then opened, and the resulting generator 

terminal voltage is recorded. Based on Figures 5 and 6, (GTG1 and GTG2), which present the generator 

terminal voltage during the excitation removal test, the value of T_do^' for STG3 and the gas units is 

calculated as follows: 

 

𝐻2 = 1.05,0.368𝐻2 = 0.3864, 𝑇𝑑𝑜
′ = 11.9 second (GTG3) 

 

𝐻2 = 1.05,0.368𝐻2 = 0.3864, 𝑇𝑑
′ = 9 Second (GTG1 and GTG2) 

 

 

 
 

Figure 5. Generator terminal voltage in excitation removal test for STG3 
 
 

 
 

Figure 6. Generator terminal voltage in excitation removal test for GTG1 and GTG2 
 

 

Figure 1: Generator terminal voltage in excitation removal test for STG3 

H2 

0.368H2 

≈ 11.9 second 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 1: Generator terminal voltage in excitation removal test GTG1 & GTG2 

H2 

0.368H2 
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4.1.2.  Direct-axis parameters test 

The objective of the d-axis test is to validate the generator's direct-axis parameters used in the 

simulation, which include the synchronous, transient, and sub-transient reactances (𝑋𝑑 , 𝑋𝑑
′ , 𝑋𝑑

′′ ), as well as the 

transient and sub-transient time constants (𝑇𝑑𝑜
′ ,𝑇𝑑𝑜

′′ ). In this test, the generator's load was reduced to the minimum 

possible value based on the field test results. The circuit breaker was opened, and terminal voltage values were 

recorded to validate the model. During the test, the generator operated at a load of 5.8 MW/-16.5 MVAR for 

STG3 and 2.3 MW/-16.1 MVAR for GTG1 & GTG2. The direct-axis parameters for steam and gas units can be 

calculated based on the generator terminal voltage depicted in Figures 7 and 8, along with (1)-(3), as : 

 

1 2 10.026, 0.03, 0.195, 0.01, 0.114,0.368 0.004A B C H H H= = = = = =  
 

''

20.368 0.042, 0.04Second, 0.12pudH T I= = =
 

 
' ''1.625pu, 0.25pu, 0.216pud d dX X X= = =

(STG3) 

 

1 20.0125, 0.017, 0.133, 0.01, 0.132A B C H H= = = = =  
 

''

1 20.368 0.004,0.368 0.05, 0.05 second, 0.076dH H T I= = = =
 

 
' ''2.1pu, 0.22pu, 0.1644pud d dX X X= = =

 (GTG1 and GTG2) 

 

4.1.3.  Arbitrary axis load rejection test  

The objective of the partial load rejection test is to validate the generator's inertia time constant by 

observing the initial increase in generator speed during load rejection. In this test, the generator operated at a 

partial load of 18 MW for GTG1 and GTG2 and 39.2 MW for STG3 when the test was conducted. The D-

axis parameters for both the steam and gas units can be calculated based on the generator terminal voltage, 

shown in Figures 9 and 10. These calculations are performed using (7) as i) 𝐻 = 6.686, where: 𝐹° =

50 𝐻𝑧, 𝑃° = 18 𝑀𝑊, 𝑀𝑉𝐴𝑏𝑎𝑠𝑒 = 134.60 𝑀𝑉𝐴,
𝑑𝑓

𝑑𝑡
= 0.5 (GTG1 and GTG2); and ii) 𝐻 = 4.497, where: 

𝐹° = 50 𝐻𝑧, 𝑃° = 39.2 𝑀𝑊, 𝑀𝑉𝐴𝑏𝑎𝑠𝑒 = 146.25 𝑀𝑉𝐴,
𝑑𝑓

𝑑𝑡
=  1.49 (STG3). 

 

 

 
 

Figure 7. Generator terminal voltage in direct-axis test for STG3 

 

Figure 1: Generator terminal voltage in direct-axis test for STG3 

C 

A B

G 

H2 

H1 

0.368H2 
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Figure 8. Generator terminal voltage in direct-axis test for GTG1 and GTG2 
 

 

 
 

Figure 9. Generator initial speed increase in 39.2 MW load rejection test for STG3 
 

 

4.1.4.  Quadrature-axis parameters test  

The objective of the partial load rejection test is to validate the generator's quadrature-axis 

parameters used in the simulation, which include the synchronous and transient reactances (𝑋𝑞 , 𝑋𝑞
′′), as well 

as the transient and sub-transient time constants (𝑇𝑞𝑜
′ , 𝑇𝑞𝑜

′′ ). During this test, the generator load is adjusted 

until the rotor angle is 90 degrees away from the reference point obtained during the direct-axis test. The 

circuit breaker is opened, and terminal voltage values are recorded to validate the model. The rotor angle for 

the turbine was 90 degrees away from the reference point taken at the direct axis when the test was 

conducted, and the generator terminal voltage for the steam unit is shown in Figure 11 and for gas units in 

Figure 12. Using (4)-(6), the turbine Q-axis parameters are calculated as follows: 
 

𝐴 = 0.97875, 𝐵 = 0.96675, 𝐶 = 0.92, 𝑇𝑞
′ = 3 sec., 𝑇𝑞

′′ = 0.15 sec., 𝐼𝑜 = 0.22 pu 

𝑋𝑞
′′ = 0.91pu(STG3)  

𝐴 = 1.027, 𝐵 = 0.9954, 𝐶 = 0.965, 𝑇𝑞
′, 1.3second, 𝑇𝑞

′′ = 0.075second, 𝐼𝑜 = 0.22 pu 

𝑋𝑞
′′ = 0.448 pu (GTG1 and GTG2) 
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4.1.5.  Open-circuit saturation test  

The open-circuit saturation test aims to validate the generator's saturation factors used in the 

simulation. The generator operates at full speed with no load during this test, and the unit circuit breaker is 

open. The exciter current varies in steps until the possible maximum terminal voltage value is recorded. This 

test can verify the accuracy and reliability of the saturation factors used in the simulation. By utilizing the 

results of the open-circuit saturation test, it becomes possible to calculate the generator saturation factors. 

Figures 13 and 14 depict the data points required to determine the 𝑆1.0 and 𝑆1.2 values specifically for the 

steam and gas turbine generating units, represented by small circles. Using (8) and (9), the saturation factors 

for STG3 and gas units (GTG1 and GTG3) can be determined as follows: 
 

𝐶 = 1.375, 𝐵 = 1.26, 𝐴 = 0, 𝐷 = 0, 𝐹 = 1.9, 𝐸 = 1.50 
 

𝑆1.0 = 0.09, 𝑆1.2 = 0.266 (STG3) 
 

𝐶 = 1.136, 𝐵 = 0.976, 𝐴 = 0, 𝐷 = 0, 𝐹 = 1.696, 𝐸 = 1.2 
 

𝑆1.0 = 0.17 
 

𝑆1.2 = 0.4 (GTG1 and GTG2) 
 

 

 
 

Figure 10. Generator initial speed increase in the 18 MW load rejection test for GTG1 and GTG2 
 

 

 
 

Figure 11. Generator terminal voltage in q-axis test for STG3 
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Figure 12. Generator terminal voltage in q-axis test for STG3 

 

 

4.2.  Discussion 

The obtained results, as shown in Table 1, demonstrate the effectiveness of the proposed method for 

deriving standard parameters of an SG using dynamic measurements. The dynamic tests conducted in PSS/E 

for this study showed that the proposed method resulted in more accurate standard parameter values than the 

other methods. The maximum error obtained using the proposed method was 2.7%, while the maximum error 

obtained using other simulation software or other methods was 5% [29], 5% [26], 5.8% [33], 4.15% [12], 

7.25% [7], and 4.8% [19]. This indicates that the proposed method has the potential to significantly improve 

the accuracy of SG standard parameter derivation. 

 

 

 
 

Figure 13. Open-circuit characteristic (OCC) test plot for STG3 
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Figure 14. Open-circuit characteristic (OCC) test plot for GTG1 and GTG3  
 

 

Table 1. Obtained values versus designed values of synchronous generator standard parameters 
Unit Gas units Steam unit 

Variable Obtained values Original values Relative error  Obtained values Original values Relative error 

𝑋𝑑 2.1 2.1 0.00% 1.625 1.63 0.50% 

𝑋𝑑
′  0.22 0.218 0.90% 0.25 0.251 0.10% 

𝑋𝑑
′′ 0.1644 0.162 1.50% 0.216 0.215 0.10% 

𝑇𝑑
′  9 9 0.00% 11.9 11.9 0.00% 

𝑇𝑑
′′ 0.05 0.05 0.00% 0.04 0.04 0.00% 

𝑋𝑞 1.5 1.5 0.00% 1.59 1.6175 2.70% 

𝑋𝑞
′′ 0.91 0.9 1.10% 0.448 0.4503 0.20% 

𝑇𝑞
′ 3 3 0.00% 1.3 1.32 2.00% 

𝑇𝑞
′′ 0.15 0.15 0.00% 0.075 0.077 0.20% 

𝐻 6.686 6.77 1.20% 4.497 4.5 0.30% 

𝑆1.0 0.17 0.17 0.00% 0.09 0.09 0.00% 

𝑆1.2 0.4 0.4 0.00% 0.266 0.27 0.40% 

 

 

5. CONCLUSION 

The study introduced a method for deriving the standard parameters of an SG, including steam and 

gas units, through dynamic tests conducted using PSS/E. The standard parameters include inludes 𝑋𝑑, 𝑋𝑑
′ , 

𝑋𝑑
′′, 𝑇𝑑

′ , 𝑇𝑑
′′, 𝑋𝑞, 𝑋𝑞

′′, 𝑇𝑞
′, 𝑇𝑞

′′, 𝐻, 𝑆1.0 and 𝑆1.2 are determined through various dynamic tests, including direct-

load rejection, excitation removal, quadrature-axis load rejection, arbitrary-axis load rejection, and open-

circuit saturation tests. Data collected from the field are utilized to verify the results obtained from these 

dynamic tests. Statistical analysis reveals that the maximum error relative to the true values is 2.7% or less of 

the design values for all standard parameters, indicating a high level of accuracy that reinforces the reliability 

and practicality of the proposed method. Furthermore, the strong agreement between simulation outcomes 

and design parameters suggests that simulation results can serve as a valuable reference for conducting 

dynamic tests in real-world scenarios. Future work will incorporate exciters, governors, and stabilizers into 

the model to assess the system's stability through dynamic tests. 
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